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INTRODUCTION

Open Plot is a free software for structural data analysis which includes some basic 3D 
functionalities. Open Plot is available for Windows and Linux operating systems and, 
soon, for Mac O.S.

Window 2000 and higher.
• Download the Open Plot Pj.zip file, which includes the software (Open Plot Pj.exe), a 

collection of libraries (folder Open Plot Pj Lib) and the gs.ini file. Extract all files in the 
same folder.

• Download the quesa_2.0_sdk_win32.zip package, free for download at: 
http://sourceforge.net/projects/quesa/files/quesa/2.0/quesa_2.0_sdk_win32.zip/download. 
Extract Quesa.dll from the folder: /Developers/DLLs/Release/ and copy it in the folder 
containing Open Plot Pj.

Linux distros including GTK+ 2.8 (or higher).
• Download the Open Plot Pj.tar.gz file, which includes the software (Open Plot 

Pj) and the gs.ini file. Extract all files in the same folder.

Run Open Plot Project.
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IMPORT DATA

Structural data can be imported from both clipboard and files or from previously saved Open Plot 
files.
When importing data from text files or copied from spreadsheets, the first step is to properly 
organise the dataset. 

How to organise data

Data must be organised as follow:
Rows = elements.
Columns = element attributes.
Eventually, the first row can contain the columns header.

Numeric fields rigorously do not have to include non numeric characters.
As an example, the azimuth must be expressed as a number ranging between 0 and 360. 
Expressions like N180º or N56E will return an azimuth = 0.

For a given element, when the value of an attribute is not defined the corresponding field must be 
empty.

Example spreadsheet with correct data organization
Data Type Azimuth Dip Pitch Spacing

Fault 123 57 24 477

Joint 345 83 35

Fault 133 48 12

Example of spreadsheet with incorrect data organization
Data Type Azimuth Dip Pitch Spacing

Fault 123 57 24 477 mm

Joint 345 83 - 35

Fault 133 48 12 /

In the correct table joint has not an associated pitch value. Analogously, the second fault has not an 
associated spacing value.
In the Incorrect table, the character “–“ in the pitch field of the joint will return a pitch = 0. Spacing 
of both faults will be set = 0, as non numeric characters are present.
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If data are loaded from a text file, each row must contain the same number of fields.
 
Correct data organization with fields divided by commas.
Data type, azimuth, dip, Pitch, spacing
Fault,123,57,24,477
Joint,345,83,,35
Fault,133,48,12,
Data in the Joint row will be read as follow: Data type=Joint; Azimuth=345; Dip = 83; Pitch = 
EMPTY (two commas with no character in between); spacing = 35. Analogously, for the second 
fault, data will be read as follows: Data type=Fault; Azimuth=133; Dip =48; Pitch = 12, Spacing = 
EMPTY.

Incorrect data organization
Data type, azimuth, dip, Pitch, spacing
Fault,123,57,24,477
Joint,345,83,35
Fault,133,48,12
Data in the Joint row will be read as follow: Data type=Joint; Azimuth=345; Dip = 83; Pitch = 35. 
The character after 35 is an “enter”. This implies that the joint row is characterised by 4 fields, 
while the first fault is characterised by 5 fields. Due to this the software will stop reading the file 
(eventually it will crash). Analogously, for the second fault data will be loaded as follows: Data 
type=Fault; Azimuth=133; Dip =48; Pitch = 12; the character after 12 is an “enter” and the software 
will stop reading.

Faults sense of slip
During data import, fault slickenline can be imported as both pitch or slickenline azimuth. 
Regardless of this, if at least one of these two field is not empty, the software will compute the 
values of: slickenlines pitch and azimuth and of rotax (slip normal) azimuth and dip. If not present 
in the imported dataset, these fields are automatically added.

In the field defining the fault's sense of slip, English nomenclature must be adopted.
A fault is considered: 
- Normal when the first two letters are NO or NR
- Reverse, when the first two letters are RE or RV
- Left-lateral, when the first two letters are LE or LL
- Right-lateral, when the first two letters are RI or RL
This check is not case sensitive.
In all the other cases the sense of slip is considered undetermined
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Import from Clipboard
This allows to import data copied from a spreadsheet. Open the spreadsheet and copy the selection 

containing data.

From the  main  window of  Open Plot 
select:

File → Import from Clipboard

If  data  are  correctly  loaded it  will  be 
asked if data  include an header (if it is 
the case it is assumed that the column 
header locates in the first row).

A new window will open up.

In the first and second list-boxes on the left are listed 
the  “software defined” and  the  “user  defined” fields, 
respectively. In the third list-box are listed the values 
associated with the selected “user defined” field.

When  possible,  select  the  “user  defined”  field and 
double  click  the  corresponding  “software  defined” 
field. This substitutes in the header the “user defined” 
field name with the “software defined” field name. 

When all  the possible  substitutions  have been done 
click “Next step”.

The  window will  enlarge  and  it  will  be  asked  to 
specify for each unassigned field if it is a Value field 
(numeric  field,  like  spacing,  aperture)  or  a  Class 
field (alphanumeric field, like author, year...)

Double-click  on  the  unassigned  fields  to  “assign” 
them and then click “Next step”.
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In  the  new  window  it  will  be  asked  to 
specify, for each element in the “Data type” 
field,  if  it  is  a  Line,  a  Plane,  a  Tensor,  a 
Vector or a Triangle.

Select/multiselect the element/s and, holding 
the  keyboard  space  bar  pressed,  drag  the 
element/s in the corresponding type list-box. 

If  planar  elements  are  present,  it  must  be 
specified if the azimuth field correspond to the plane dip direction or to the plane strike.

In this window, a given type list-box is enabled only if loaded elements include fields that are 
required by that type:

To define a Line and a Plane the azimuth and dip fields must exist.

To define a Tensor the azimuth and dip fields of the three eigenvectors must exist (the eigenvalues 
are optional).

To define a Vector the three coordinates of the starting and ending points must exist.

To define a Triangle the three coordinates of the three points must exist.

Notice that for Vectors and Triangles the software will automatically compute the azimuth and dip 
values.

Finally you can decide to save the data as *.stv file or continue without saving.

If coordinates have been loaded, it will be asked to specify if the X,Y and Z 
coordinates are in  Polar or Cartesian system.  In the first case, it must be 
also introduced the Sphere Radius.  In this early version, only a limited  
suite of operations are fully supported for Polar coordinates
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Import from file
The procedure is the same as described in the  Import from clipboard, with the exception of the 
following initial steps.

From the main window of Open Plot select: File → Import from File and select the file. 

In many  Linux distros the OpenDialog could not correctly work. If it is the case from the main 
window of Open Plot select: File → Drawing options. A new window will open. Select the  Plot 
Option tab and activate the Linux Dialog Problem option (placed at the bottom of the list).

Import  from File  needs  the  separator  definition, 
which  have  to  be  specified  in  this  window that 
will automatically open.

Open Open Plot files

Loaded data, data created within the software and other imported 3D objects can be saved in both 
*.stv (data file) and *.spj (project file) format and then read back.
These two format are identical, with the only exception that images can be saved in *.spj format.

To open a previously saved file, from the main window of Open Plot select:
File → Open data file (*.stv file).
File → Open project (*.spj file).
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SELECT DATA

Once data have been loaded, you can select a subdataset. 

From the main window select: 

Data → Selection. This window will open.

In the list-box on the left all the class fields are listed.

Clicking the closure/disclosure triangle near to the class field will  show/hide all the Values of the 
class.

Click the check-box to select/deselect a given value. When, for a given Class Field, all the Values 
are unchecked, it implies that all the Values are automatically selected.

You can also assign a colour to a Value by clicking the Colour-box.

In the second list-box are listed all the Values fields. When clicking on a given Value field the 
corresponding histogram will be shown (red bars in the figure above).

To select a range move/resize the red rectangle below the histogram and click the “Add selection” 
button or manually define the range in the Min/Max edit-fields and click “Add selection”.

This allows to create multiple selections for one or more Value fields. Clicking on a given Value 
field will display all the associated selections ranges in the third list-box. 

To remove a selection for a value field just select it in the third list-box and press “Canc” on the  
keyboard.
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Once a Selection has been created, you can apply it.

Selection → Apply:

Applies  the  selection  and  the  colour  code.  In  this  case  it  must  be 
specified which Class field controls the colour code (click the check-
box of the Class field).

Selection → Fast apply: Applies the selection without colour information.

Selection → Apply and save: Applies the selection and the colour code and save the selection.

Selection → Load: Loads and applies a saved selection.

Selection → Clear. Deactivates all the selections and restore the dataset to the original (all the data 
are selected). 

Selection → Erase: Erases the selected data.
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PLOT DATA

Stereoplot

Select: Plot → Stereoplot

All the selected data are sent to this window.

In the two list-boxes on the right you can select data according to their type and sense of slip, and 
can specify which attribute will be plotted for each element.

Plot → Stereoplot:

Plot data in stereographic equal-area projection.
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Plot → Contouring:

Plot  data  contour  in  stereographic  equal-area  projection.  Data  contour  can  be  computed  using 
classical Kalsbeek method (Plot → Contouring → Kalsbeek) or using a Gaussian data smoothing 
procedure ( Plot → Contouring → Gaussian Smooth), which produces more “smoothed” contours.

Plot → Data Regression:

Applies a tensorial analysis and a conical regression to the selected data.
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The Regression results are displayed in a new window. They include eigenvectors azimuth and dip 
and the corresponding eigenvalues, and cone axis azimuth, dip and conical angle.

The  three  buttons  in  this  window  allow  to 
assign azimuth and dip of a given eigenvector 
to the selected dataset (notice that in this case 
selected data includes not only the plotted one, 
but  all  the selected data).  The aim of this  is 
discussed in the 3D section.

Stereoplots overlay:

Eigenvectors  and  conical  regression  are  also 
displayed in a small  stereoplot at the bottom of 
the window. To visualise it drag it in the main 
stereoplot.

The main stereoplot can also be stored in small stereoplots on the right side of the window. Stored 
stereoplot can be dragged in the main stereoplot. This allows to overly contourings, stereoplots and 
regressions, as in the example below.
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In this portion of the window can be modified the colour code for contour fill, the 
minimum and maximum values and the number of intervals.  Just  modify the 
value and press “Enter” to redraw.

The size and stroke of many drawing features can be customised by modifying their values in the 
window that appears when clicking in the main window File → Drawing options.

Plot → Fill contours:

When this option is activated contours are filled.

Plot → Rotated data:

When this option is activated data are projected in their rotated orientation. A rotation axis must be 
defined. To achieve this, in the main window, select Rotate Data.

In  the  window  that  will  open  it  must  be 
defined the rotation axis.

When  “user  defined”  option  is  activated  it 
must be specified the azimuth, the plunge and 
the rotation  angle,  which  apply to  the entire 
dataset.

When “use field” option is  activated,  double 
click  in  the  three  list-boxes  to  define  which 
field, of each datum, will be used to define the 
rotation  parameters.  This  option  allows,  for 
example, to rotate each datum according to its 
reference bedding. The strike of bedding is the 
rotation axis strike, the rotation axis plunge is 

0 (leave the corresponding field empty), the bedding dip is the rotation angle.  It is important to 
remark that to rotate data around a reference bedding, the reference bedding azimuth MUST be 
introduced as strike of the bedding, NOT as dip direction.

The rotation axis must be specified before plotting data (eventually close the Plot window, define 
rotation parameters and the click Plot → Stereoplot again).

Rotation parameters can be used to plot rotated data in the Plot window or to rotate data and save 
the rotated dataset.
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A pop-up menu appears when right clicking within the stereonet, displaying 4 options.

Save as SVG: Save the main stereoplot  in Scalar Vector 
Graphics format. This is a vectorial format that can be read 
by  the  most  part  of  Windows  and  Linux  softwares  for 
vectorial graphic.

In  order  to  save  file  as  SVG,  in  the  drawing  options 
window (Main  window → drawing Options)  it  must  be 
checked the SVG writing option.

Copy as raster: Copies the main stereonet as a raster image in the clipboard, which can be pasted in 
drawing software.

Add point of view:  Stores a direction (corresponding to the mouse  position within the stereonet). 
The stored directions can be used in the 3D window and their purposes are discussed later. Notice 
that every time data regression is applied, the maximun and minimum eigenvectors directions are 
also stored.

Clear points of view list:

Removes all the stored directions.

In  the  stereoplot  window can be also selected  a 
sub-portion of the dataset. From the menu select: 
Draw  selection  →  activate  selection  drawing. 
Draw  a  selection  containing  data  you  want  to 
select and then right-click with the mouse.

Two  new  options  are  displayed  in  the  pop-up 
menu, which allow to assign a colour or select the 
data. Notice that to re-plot data you have to exit 
and then, from the main menu, re-select:

Plot → Stereoplot.
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Frequency analysis

Select: Plot → Frequency analysis

All the selected data are sent to this window.

In  the  list-box on top-left  are  listed  all  the  Value  fields.  Select  a field  and the  corresponding 
histogram will be drawn. Statistical attributes will be listed on the lower-left border of the window. 
These include the average value, the standard deviation, the skewness, the kurtosis and data number. 
In the case of circular data are displayed only the circular mean, the circular standard deviation and 
the data number. You can specify X and Y limits, if the data are logarithmic or circular and, in this  
case, if you want to analyse the semi-circular range. The number of intervals can be set by moving 
the slide-bar. Data can be saved as SVG (mouse right click), provided “SVG writing” is allowed in 
the in the drawing options (Main window File – > Drawing Options).

The  clustering  of  the  population  can  be  analysed  with  the 
mean shift analysis. Input parameter is the seeking interval (or 
smoothing radius), expressed as a percentage of the X-interval

Results of mean shift analysis are listed in the list-box on the 
right side of the window and include, for each sub-population, 
the boundaries, the mode and the data number.

These can be copied by right-clicking the list-box.
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Scatter plot 

Select: Plot → 2D Scatterplot

All the selected data are sent to this window.

Select the X and Y axes from the list-boxes on top-left (double click the field) and a scatterplot will 
be drawn.

There are three options for plotting data. 

• Data option: plots a scatterplot. The size of point can be customised in the Drawing options 
(Plot options tab: scatterplot circle width and stroke).

• Interval option: divides the X axis in a number of interval defined  by the slide-bar value. 
Define if Y-values are normal or circular and then click “Apply”. For each X-interval are 
computed the average value, the standard deviation and, for non circular data, the skewness 
and the kurtosis of the Y field. Select the parameter to be plotted, eventually change the Y 
scale, and then click “draw”.

Open Plot Project.  2010 Alpha release. User's Manual page 17 TOC



• Frequency option: draws frequency contours.

To draw contours you have to specify:

• The grid size (Y and X intervals).

• If Y and/or Y values are circular

• If data have to be normalised to the relative maximum in the corresponding X or Y interval 
or to the absolute maximum of the grid.

• The distance parameter, i.e. the distance between a datum and the cell's centre

• The smoothing (i.e.the number of nearest cells on which perform the smoothing)

• The number of contours

Once the contouring has been drawn, it can be also exported as *.dat file.

There is a still unresolved bug in the contour routine and, 
in rare cases, contours are incorrect (like in the example 
on the right). Just change the number of contours or 
slightly modify the Distance parameter (e.g. if distance is 
4, set it to 4.001).
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Right-click within the graph.

Copy to clipboard: copies the X and Y values of plotted data

Save as SVG: save the plot in *.svg format (if SVG writing is enabled).

Select: Plot → 3D Scatterplot

All the selected data are sent to this window.

The functionalities of the 3D Scatter plot are similar to those of the 2D, with the exception that in 
this version of Open Plot, many of them are not yet implemented.

To zoom or rotate the plot hold pressed Shift + Ctrl (zoom) or Ctrl (rotate) and drag the mouse.
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MANAGE DATA IN 3D

3D view window

From the main window select: Plot → 3D view

All the selected data will be displayed in the 3D space, provided coordinates information exist.

Navigation

Camera Position

The default view is from Top and can be changed by selecting different points of view from 
the drop-down menu in the 3D window (button N13).
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Zoom

Press button 1 and then, holding Ctrl, Shift and the mouse left button, move the mouse up 
and down to zoom in and out. Alternatively, press button N 14 and, holding pressed the 
mouse left button, move the mouse up and down. In this second case, to deactivate zooming 
press button N 1.

Move camera

Press button 1 and then, holding Shift and the mouse left button, move the mouse. 
Alternatively, press button N 15 and, holding the mouse left button, move the mouse up and 
down. In this second case, to deactivate moving press button N 1.

Rotate camera around a point

1 – Rotate around a point in the centre of the scene. Press button 1 and then, holding “Ctrl” 
and the mouse left button, move the mouse. Alternatively, press button N 16 and, holding 
the mouse left button, move the mouse 

2 – Rotate around a vertical axis lying in the centre of the scene. Press button N 17 and, 
holding the mouse left button, move the mouse left and right.

3 – Rotate around an horizontal axis lying in the centre of the scene. Press button N 18 and, 
holding  the mouse left button, move the mouse up and down.

For options 1 to 3 the position of point/axis around which camera rotates can be moved 
forward/backward by holding the Ctrl button and moving the mouse wheel.

4 -  Rotate around a point defined by the user. Press button N 19 and, holding the mouse left 
button, move the mouse. The point around which camera rotates is the point clicked by the 
user, which is repositioned in the centre of the scene. If the user clicks in the empty space, 
rotation is performed around the centre of the dataset.
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3D Objects 

Open Plot allows visualising and managing loaded data in 3D.

Other 3D objects can be loaded/created, including:

Dip domain: Polygon with nodes lying along the same plane

These elements can be created only within the software, can be saved in both *.stv and *.spj format 
and read back, and exported as 3D surface in *.DXF format. 

Dip domains have associated azimuth and dip values and can be plotted in stereoplot.

Polyline

This element can be created within the software, can be saved in both *.stv and *.spj format and 
read back, can be exported in *.DXF format, imported from *.DXF file, imported from both 
clipboard and file. Azimuth and dip of polylines can be plotted in stereoplot in two ways:

MODE I: it is computed the azimuth and plunge of each segment.

MODE II: it is computed the azimuth and dip of the segment connecting a node with the centre of 
mass.

Panel: vertical polygon with nodes lying  at two fixed elevations.

These elements can be created only within the software, can be saved in a *.stv and *.spj format and 
read back. Panels cannot be exported. Images can be draped on panel. Data can be projected along 
the panel.

Selection: closed panel.

These elements can be created only within the software, can be saved in a *.stv and *.spj format and 
read back. Selections cannot be exported. Selections allow to select data that are included within the 
selection.

Mesh:

These elements cannot be directly created within the software and can be saved only in *.spj format. 
Can be exported in *.DXF format and imported from different file types. Georeferenced images can 
be draped on meshs.

Image list:

A list of images with an assigned position. These elements can be created only within the software, 
can be saved in *.spj format and read back. They cannot be exported. To avoid file size increase, the 
loaded images are re-sampled and transformed in JPG format.

Map

Georeferenced images that can be draped on meshes. These can be saved only in *.spj format.

Texture

Images that can be draped on panels. These can be saved only in *.spj format.
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Draw, load and edit 3D object
Drawing objects using polyline tool

Press button 2 and click with the mouse left button on the non-empty space.

Press “Esc” to remove the last added point. A yellow sphere is drawn for each node. The size of this 
sphere is not scale-dependent and must be manually set in the drawing options → 3D options → 
points in 3D view.

If, in the drawing options → 3D option, the dip domain 
from polyline option is activated (value = 1), while 
drawing a polyline the best-fit plane will be automatically 
drawn, including a white panel on which are plotted the 
quality of fit, for each point.

Once you have finished drawing the polyline, click on 
the edit tab.

Press the “Polyline” button. The polyline will be added 
to the dataset. The Unit selected in the upper list-box of 
the Object panel will be assigned to the polyline.
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Press the “Panel” button and a panel, passing trough the drawn nodes, will be created.

Press “Selection” button and a selection, passing trough the drawn nodes (the first and last ones will 
be linked), will be created.

Press D.D. Button and the best-fit Dip Domain will be created.

Panels, Dip domains and Selections can be created also from existing polylines. To do this press 
button N1, select the polyline, go to the edit panel, press button 3 and press Panel/Selection/D.D. 
Button.
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Polyline

The procedure for drawing a polyline has been previously discussed.

Polyline can be imported from *.dxf files:

Main window → Objects → Import DXF

Polyline can be imported from a text file:

Main window → Objects → Import Polyline → Import from file

Polyline can be pasted from the Clipboard:

Main window → Objects → Import Polyline → Import from Clipboard

In the last two cases the file/copied data must be organised in three columns, without header, 
including the X, Y and Z coordinates of each node. In both cases it will be asked to specify the Unit 
of the imported polyline.

When a polyline is selected in the 3D view (press button N1 and then click on the polyline) and 
button N3 has been pressed, you can modify the polyline. Go to the edit tab

• Select a node using the small arrows buttons and reposition the point by clicking with the 
mouse left button on a non-empty position and then press the “modify” button.

• Select a node and split the polyline.

• Select and remove a node.

• Select a node and add a new node.

• Flip the node order.

• Clicking the edit button will show a list-box with the nodes coordinates. These can by 
copied (mouse right-click). New nodes can be pasted in this window (the old one will be 
overwritten).

• Erase the polyline
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Dip Domain and Axial surface

Dip Domains can be created from polylines, added by using points of view defined in the stereoplot 
window, added by using the “Polyline to dip Domain analysis”.

The procedure for creating Dip domains from polylines has been previously discussed.

Creating a dip domain from a stored Point of View includes two steps:

1. Go in the stereoplot window and right-click with the mouse in the position corresponding to 
the pole of the desired plane (a plot must exist). From the pop-up menu select Add point of 
view. Notice also that each time a tensorial analysis is performed, the directions of 
eigenvectors associated with the maximum and minimum eigenvalues are stored.

2. In the 3D window right-click in the position where the dip domain must be created. If stored 
directions exists, in the pop-up menu select add Dip domain and select the value from the 
list of the stored directions.

The Unit of the new dip domain is that selected in the upper list-box of the Object panel.

Polyline to dip Domain analysis

Press button 11 and then select/deselect polyline/s. On the keyboard press Y to start the analysis on 
the nodes of the selected polylines.

The software will seek for the bigger dip domain satisfying the conditions defined in the drawing 
options/Planar regression. These includes:

• Maximum value of the minimum eigenvalue.

• Maximum value of the ratio between the maximum and medium eigenvalues.

• Minimum number of points

• Maximum distance of points from the centre of the dip domain.

• Minimum seeking radius. This parameter (expressed as %) set the tolerance to “empty” Dip 
Domain. In other words, avoids the creation of dip domain which include only points 
located far from the centre of the dip domain.

Once the bigger dip domain is found, nodes included in this domain are extracted from the dataset. 
This procedure is recursively applied until domains accomplishing for the setted conditions are 
found.

The Unit of the new dip domain is that selected in the upper list-box of the object panel.

Drawing options/Planar regression includes others three options

Dip Domain evaluation allows the visualization of regression results (significantly increases the 
computational speed). In particular this allows to plot, for each dip domain, data that project on the 
dip domain, with a distance from the domain defined by the Upper and Lower distances.
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To modify a Dip Domain press button N1, select the dip domain and go to the edit panel.

In the lower portion of the tab are listed the attributes of the Dip 
Domain.

In the upper portion there are three group-boxes:

Plane:

%: Resizes the panel.

X, Y, Z: Move the the panel along its strike, dip direction, normal 
direction..

For these operation the % and the amount of displacement are defined 
in the red box.

Points:

< and >: Select a node of the Dip Dpmain.

X and Y: displace the node along the domain strike and dip direction.

- and +:add and remove a node

Rotate:

Rotate the plane (the angle is defied in the red box) around the vertical 
axis (V); the strike direction (A), dip direction (D) and around a user 
defined direction (C) (in this case azimuth and plunge must be 
introduced in the blue boxes).

In the central portion of the tab the “plot” button draws a stereoplot including all the selected data 
that project on the dip domain, whose distance from the domain is lower that that introduced in the 
green boxes.

Clone and Erase buttons clone and erase the selected dip domain.

The slide-bar set the transparency of the dip domain. This option, which increases memory usage, 
properly works only on Windows O.S.

Axial surfaces are a particular class of dip domain, whose functionality is discussed later.
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Panels

The procedure for creating a panel from polyline has been previously discussed.

Similarly to polylines, panels can be imported from both text file and clipboard:

Main window → Objects → Import Panel → Import from file/Import from Clipboard

When a new panel is created, the Upper and lower Z coordinates of the panel are automatically 
defined and correspond to the upper and lower Z coordinates of the dataset.

To edit or perform operations press button N 1 and then select the panel.

In the upper part of the tab are listed 
the textures that can be applied to 
the panel. The first option is “No 
texture”. Select it and press Apply 
button. A simple colour will be 
applied.

In the same list box are listed all the 
loaded textures, select the desired 
one and click apply. Slide-bar 
allows to set texture transparency.

Notice that when a file is saved in 
*.stv format, images are not saved. 

Images (including textures) are saved only in *.spj format. In this case the association between the 
panel and the texture is saved too.

To change the upper and lower Z coordinates of the panel use the boxes below the upper list-box

To erase a panel click the Erase button.

Section button project data onto the panel, in particular a new picture is created (you will be also 
asked to save it as *.svg file), where elements apparent dip and plotted.

Plot button projects data onto the panel. Data are send to the scatterplot window, adding along-panel 
X and Z coordinates.

For both section and plot, projection direction must be defined. The default is perpendicular to 
panel, directions stored in the point of view list can be used (in this case the projection direction is 
the same for each datum). A third option is to project data using a saved eigenvector direction (See 
stereoplot section). In this case, in fact, different data can have associated different eigenvectors.
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Selections

The procedure for creating a selection from polyline has been previously discussed.

To edit or perform operations press button N 1 and then select the selection.

In the Edit tab you can erase the selection or apply it. In the second case, all the data having X and 
Y coordinated within the selection will be selected.

Selections can be saved in both *.stv and *. spj format.

Meshes

Triangular meshes can only be imported. These element can be loaded as both “active” (Main 
window – > import mesh + triangles) and “inactive” (Main window – > import mesh or imported 
*.DXF files).

For active meshes each triangle will be loaded and can be edited/selected/plotted/erased. Active 
meshes are saved in both *.stv and *.spj format.

Inactive meshes are not editable and can be saved only in *.spj format.

In the 3D window, press button N1, select the mesh. In the list-box of the edit tab, you can apply a 
colour code defined by the Z coordinate or drape a georeferenced image on the mesh.

The association between the mesh and the georeferenced images is saved only in *.spj format.
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Image list

Photo can be loaded and then saved in *.spj format. Right 
click, in the 3D view window, at the desired location.

Insert and erase images and draw on them.

Map

Maps are georeferenced images that can be draped on both meshes and top_box and bottom_box . 
To load a map in the main window select:objects → load map.

In the window that will open up load the map and georeference it (for JPG files with associated 
*.jgv file, coordinates are automatically loaded).

Texture

Textures are non georeferenced images that can be draped on panels. To load a map in the main 
window select:objects → load texture.

In the window that will open up right-click on the list-box and load an the image. 

Maps, textures and inactive meshes can be erased by selecting, in the main window: Object → erase 
objects
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Additional functionalities of the 3D view window includes:

• Draw vectors: click button N 4 and then click on the positions corresponding to the starting 
and ending points of the vector.

• Join two polylines: click button N5, select two polylines and press Y.

• Divide a dip domain: click button N6, select two dip domains (or one dip domain and an 
axial surface) and press Y. If these domains intersect the first one will be divided in two 
parts along the intersection with the second domain.

• Create axial surfaces: click button N7, select two dip domains and then press Y. Two axial 
surfaces bisecting the dip domains pair will be created.

• Reflect planes: click button N8, select dip domains and one axial surface. The selected 
planes will be reflected (the original are not erased) according to the axial surface.

• Move planes: click button N9, select dip domains and, holding the tab key, move the planes.

• Rotate planes: click button N10, select dip domains and axial surfaces. Holding Ctrl key, 
click on a point in the non empty space and move the mouse holding pressed the left button, 
the planes will rotate around that point.

• Re-define the data boundary: click button N12.

• Define a temporary selection: click button N21 and draw a polygon. Right-click with the 
mouse and select one of the following options.

◦ Send to stereoplot: Send data within the polygon to the stereoplot window

◦ Send to Frequency analysis: Send data within the polygon to the frequency analysis 
window

◦ Select: Select data within the polygon and re-plot the 3D view.

◦ Assign colour: Define a colour for data within the selection.
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UTILITIES

These are small utilities that do not require data loading.

Elements rotation

From the main menu select: Utilities → Element rotation

Insert fault data. Fault pitch is computed from slikenlines azimuth and vice-versa. If a rotation axis 
is provided, rotated fault data (including the sense of slip) are computed.
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Slickenlines from Riedel elements

From the main menu select: Utilities → Slickenlines from Riedel elements.

Insert fault and fault-related element attitudes, select the Riedel's element type, and both fault's slip 
direction and sense will be computed.
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DRAWING OPTIONS

In the main window select: File → drawing options.

In this window can be set drawing 
parameters and other options.

The window is organised in four tab: 
Plot options, 3D options; Planar 
regression, System setting

On the bottom, right-hand/dip direction 
option-button define if, when a datum is 
selected in the 3D window, its azimuth is 
displayed as RH or dip-direction.

Text size allows to set the size of text in 
all the controls of the software. The text 
size is set each time a window is open. 
Accordingly, to make effective the 
change the windows must be re-loaded.

In the Plot options tab, the size and line-stroke of symbols used in the stereoplot window can be 
modified.

In this tab, the last four options are:

Write SVG file. When active each time a 
plot is drawn a svg file is stored, which 
can be eventually saved. This option is 
memory-consuming when a lot of data 
are plotted (as an example > 1000 planes 
in stereoplot). Deactivate this option if 
you wish to increase the computational 
speed and do not wish to save the plot.

Scatterplot circle width and stroke. Set the dimentions of circle used in 2D scatterplot.

Pitch angle. Define the boundaries (i.e. pitch angle; 180-pitch angle) between dip-slip and strike slip 
kinematic when data are rotated and fault kinematics is recomputed. As an example, if the pitch 
angle is set to 35, when rotating a fault if the “rotated” pitch of the fault is <35 or > 145, the 
kinematics will be right-lateral/left lateral.  
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In the 3D options tab can set options for 
used in the 3D view window.

Transparency for 3D surface set the 
initial transparency of dip domains (this 
option is, however, depreciated and will 
be soon erased).

Points, lines, planes and tensor 
dimensions set the size of these objects 
in the 3D window.

3D camera speed set the 
rotation/shift/zoom speed.

Data in 3D has three options:

(0=no edit) data are visualised but are 
not editable, the entire dataset is treated 

as a mesh (named data) and, in the 3D view window, can be shown/hide by clicking it in the 
Objects tab; (1= Edit) data are visualised and are editable, information associated with each datum 
is displayed in the edit tab (this option reduce the rendering speed); (2=station) data are visualised 
as a sphere (its radius is defined by the option points in 3d view), whose location is that of the field 
site.

Dip domain from polyline. If this value is set = 1, while drawing a polyline in the 3D view the best-
fit plane will be automatically drawn, including a white panel on which are plotted the quality of fit, 
for each point.

Images list width. Set the size of the rhombus used to display the position of the images list.

Draping mode and pixel map border. Each time a map is 
loaded, a border is added, whose size is defined by the 
pixel map border. This is used to avoid a problem that 
exists  when  an  image  is  draped  on  a  mesh  which  is 
greater than the map, and that results in the repetition of 
the  image  on  the  mesh.  By  enlarging  the  pixel  map 
border and setting the draping mode = 1 this repetition 
should be avoided. 

However, draping mode = 1 is still under development 
and when this option is  activated the result  should be 
carefully evaluated, to avoid “errors” like in the picture 
to the right.
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The planar regression tab includes parameters used in the Polyline to dip Domain analysis.

Finally, in the system setting tab two options are present. These relate with two problems 
encountered in linux and windows O.S, respectively.

Linux dialog problem activate an alternative open/save file window if the “normal” window takes 
long times to activate (problem encountered in Ubuntu version lower than 9.04).

3D window resize problem relate to a problem that may occur when resizing the 3D view window. 
The draw is not correctly resized. The activation of this option should solve the problem. This, 
however, increases the rendering time (only when the window is resized/maximised).
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STV AND SPJ FILES FORMAT

stv format

When data are correctly loaded, these can be saved in *.stv format.

It is a text file including strings.

The first line is used to check if the file is really an stv file, and includes the string  “tav_ro_ba”. If 
data position is in polar coordinates, the first line is “tav_ro_ba#sphere radius”, where shere radius 
is the radius of the sphere (e.g. 6.372795e+6).

The second and third lines include the number of rows and columns of the dataset, respectively. The 
data matrix indexes are 0 based, so that the number of rows and columns is, actually, rows+1 and 
columns+1.

In each row the data are divide by the “tab” character [chr(9)].

The first row includes the columns header. The header (i.e. the field) includes at the beginning two 
reserved characters: “./” or “//”, indicating that the column includes numeric and alphanumeric 
characters, respectively.

Columns number is that of “visible” fields (i.e. those imported) + 10 “reserved” columns.

The first reserved column includes the colour of the element, expressed as “&RRGGBB”, where 
RR is the RGB value of Red in hexadecimal, GG is the value Green in hexadecimal, and BB is the 
value of Blue in hexadecimal.

The second reserved column is filled only for Dip Domain and Axial Surfaces. It contains three 
versors, corresponding to the strike, dip direction and normal of the plane. These are stored in the 
form of a string S, being S =“s1.x#s1.y#s1.z/s2.x#s2.y#s2.z/s3.x#s3.y#s3.z. To get this datum, past 
the string in a spreadsheet and then apply “text to columns” function twice. The first time use “/” as 
separator, the second use “#”.

The third reserved column is, again, filled only for Dip Domains and Axial surfaces. It includes 
triangulation parameters. Triangles are written as: 
“t1.p1#t1.p2#t1.p2/t2.p1#t2.p2#t2.p3/........../tn.p1#tn.p2#tn.p3

The fourth and fifth reserved columns “store” strike and plunge of directions eventually applied 
during regression analysis.

The sixth reserved column is filled only for dip domains, axial surfaces, polylines, panels and 
selections. It includes the array of points of these elements, written in the same way of dip domain 
versors (i.e. x1#y1#z1/x2#y2#z2/......xn#yn#zn

The seventh  and eighth reserved columns are used to select/deselect data. 
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For a deselected datum the field value is =”deselecionado&deselezionato”

For a selected datum the field value is =”selecionado&selezionato”

The ninth reserved column is, again, filled only for dip domains. It includes the transparency value 
(ranging between 0 and 1) that will be applied in the 3D view.

The tenth reserved column indicate the element type

Line is “linea”

Plane is “Piano”

Vector is “vettore”

Tensor is “tensore”

Triangle is “triangolo”

Polyline is “polyline”

Selection is “selection”

Panel is “panel”

Dip domain is “DD”

Axial surface is “AS”

Point is “punto”

These declarations, when read by the software, are case-sensitive and shouldn't be manually 
modified. Also because when an unknown element is found, software crashing could occur. The 
most part of these declaration are not in English language to discourage the direct typing in this 
column.

Once an stv file have been imported in a spreadsheet, data/fields can be modified,erased or added, 
the entire dataset can be copied (remember to include the “tav_ro_ba” header) and pasted in the 
software, that will recognise the format and will not ask you to pass through the import procedure.

It is important to remark that:

• If you are adding a column, remember that the column header must be specified, including 
the “./” and “//” characters. As an example, if you wish to add a column which includes the 
ratio between fracture spacing and height, add the column, add the values and then, in the 
row including columns header, add “./SdivH”

• If you are adding a datum, remember to fill the tenth reserved column (i.e. element type)

• In all the cases, when the number of rows or columns have been changed, the second and 
third lines (including rows and columns numbers) must be updated. These number are 0-
based and accordingly, correspond to the number of columns-1, and to the number of row-1 
(including the header row).

• Always check the spreadsheet cells format. As an example, if a numeric column is formatted 
in the spreadsheet as “Date”, when the dataset is pasted back in the software an error will 
occur.
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spj format

data, simple and complex 3D objects can be saved in spj format. The structure of the file is, in its 
first part, identical to that of a stv file. In the second part are written meshes and images. The last 
ones are written in binary format and, accordingly, spj files cannot be easily read.

After the header, the number of rows and columns of data, and the data, are written meshes and 
images (maps and textures).

Once a spj file has been loaded, included data can be saved as stv file. On the other hand, as new stv 
file can be loaded, without affecting the meshes and images, that will continue to be present.
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UNDER DEVELOPMENT

There are many functionalities not yet fully implemented in this first release of Open Plot project 
and many bugs are not yet fully resolved. These are listed below, sorted by importance.

• Exported DXF files are not yet “recognised” by few software.

• Many functionalities of the 3D View window are not implemented for data having Lat/long 
coordinate system.

• In the stereoplot window, filled contours with holes are not yet “resolved”.

• Frequency contours are not yet implemented in the 3D Scatter plot.

• The aspect of many objects in the 3D View can change when data are plotted as editable or 
not editable, and many object are represented with shapes that have to be “improved”. As an 
example, tensor are represented as spheres. 

• Dataset cannot be directly created within the software.

• The appearance of objects in the stereoplot window is not yet fully customisable.

• Possibly more.....
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